Difference between revisions of "Compiling"

(remove superfluous options)
(Library dependencies)
Line 13: Line 13:
  
 
<pre>
 
<pre>
aptitude install libxi-dev libncursesw5-dev libxt-dev libxslt1-dev libxmu-dev libxmu-headers byacc flex libtnt-dev libxext-dev libpng12-dev zlib1g-dev libsm-dev libx11-dev libxau-dev tk8.5-dev tcl8.5-dev tk8.4-dev tcl8.4-dev itcl3-dev
+
aptitude install libxi-dev libncursesw5-dev libxt-dev libxslt1-dev  
 +
libxmu-dev libxmu-headers byacc flex libtnt-dev libxext-dev  
 +
libpng12-dev zlib1g-dev libsm-dev libx11-dev libxau-dev  
 +
tk8.5-dev tcl8.5-dev tk8.4-dev tcl8.4-dev itcl3-dev
 
</pre>
 
</pre>
  

Revision as of 20:22, 9 February 2010

Compiling BRL-CAD

BRL-CAD source files contain an INSTALL file with general instructions. This page contains tips for building on specific systems.

Debian / Ubuntu

Tools

aptitude install build-essential libtool

Library dependencies

aptitude install libxi-dev libncursesw5-dev libxt-dev libxslt1-dev 
libxmu-dev libxmu-headers byacc flex libtnt-dev libxext-dev 
libpng12-dev zlib1g-dev libsm-dev libx11-dev libxau-dev 
tk8.5-dev tcl8.5-dev tk8.4-dev tcl8.4-dev itcl3-dev

Configure

./configure --enable-optimized

Make and Install

make
sudo make install

Troubleshooting

If make returns an error complaining that libitk.la cannot be found, make sure you have libtool installed then do:

./autogen.sh
make noprod
make

History

These tips gleaned from knudfl and #brlcad. Tested by JamesVasile on Ubuntu Intrepid with BRL-CAD 7.14.8.